ReCaptcha V3 - No callback, uses PrimeFaces, 100000

#1
This is for the site: https://www.civitekflorida.com/ocrs/app/search.xhtml

I've tried everything from interrogating the ___grecaptcha.cfg object, to trying to inject a solved token into the g-recaptcha-response textarea and then submitting the form manually, and nothing seems to work. This site in particular has only a single g-recaptcha-response-100000 element.

I'm using 2Captcha to retrieve a solved token, yet when I look at the Network trace it appears that the grecaptcha.execute is called on submit of the form.

When I observe the calls made out, a call is made to:
https://www.google.com/recaptcha/api2/reload?k=6Le79roZAAAAAKObqCUdvf-A55u2rrtGY6Zp-W5 and it responds with a new token that is then passed to the site's custom validateUser function.

Annotation 2020-10-26 085152.png

I have a feeling there's something going on with the PrimeFaces implementation getting in the way maybe by some sort of verification mechanism I'm just not seeing.

When I manipulate the call and execute validateUser with my solved key from 2Captcha, it never proceeds to a next page, it just sort of looks to stop, with no errors.

Anyone up to taking a look to see what's going on with this page?
Even when there are no results, the site should show a message on top in red stating there are no records, that's when you know the call went through, otherwise it won't show any indication of having submitted successfully, it'll just sit there.

The address to the site I'm trying to crack is:
https://www.civitekflorida.com/ocrs/app/search.xhtml

It might have you select a county on a preliminary screen, I choose Hendry for my example down below. This should return a page with a table having one result.

Annotation 2020-10-26 085047.png

Annotation 2020-10-26 085236.png
 

Attachments

Last edited:
#3
I hope you already received the solution from our support team.
But anyway sharing it here. You need to redefine onSearch function removing grecaptcha.execute call and then use the token from 2captcha API.
A video showing how does it work: https://www.dropbox.com/s/eqhlpsjk6htpugd/civitekflorida.mov?dl=0
It does not work in 100% of cases as the score can be not enough and there's no way to get a guaranteed score.
This solution worked well for me. Thank you.