Unsolvable ReCaptcha v2 Invisible

#1
Hi, the other day I came across ReCaptcha v2 Invisible, which is not solved with Decaptcher, I am using provider 2Captcha, the problem is reproduced only on instacart.com
How to reproduce:
1. Open the page https://www.instacart.com/
2. Click Log In
3. Enter credentials and click Log In
4. Having received the captcha, we send a request to the Decaptcher:
Using Ruby and REST API
Ruby:
#### The rest of the code
curl.url = "https://2captcha.com/in.php?key=#{API_KEY}&method=userrecaptcha&googlekey=#{sitekey}&pageurl=#{url}&invisible=1"
curl.perform
#### The rest of the code
curl.url = "https://2captcha.com/res.php?key=#{API_KEY}&action=get&id=#{action}"
curl.perform
or C# SDK
C#:
ReCaptcha captcha = new ReCaptcha();
captcha.SetSiteKey("6LeN0vMZAAAAAIKVl68OAJQy3zl8mZ0ESbkeEk1m");
captcha.SetUrl("https://www.instacart.com/");
captcha.SetInvisible(true);
// The rest of the code
Note: The captcha on the decaptcha's side is solved, the token comes
5. Insert the token into //textarea and execute the callback

JavaScript:
document.getElementById("g-recaptcha-response").innerHtml = "Decaptcher token over here"
___grecaptcha_cfg.clients[0].B.B.callback("Decaptcher token over here")
// .B.B. sometimes changes
6. The form is submitted, but the instacart server returns an error in the graphql response. It looks like the token from the Decaptcher is wrong
JSON:
{"data":{"createUserSession":{"errorTypes":["forbidden"],"__typename":"SharedError"}}}
And so it is constantly, however, the captcha can be solved independently and in this case everything works. You can also open another browser (with a different User Agent, Cookie, Proxy, etc.) instead of Decaptcher, solve the captcha there and copy the token from the response 'https://www.google.com/recaptcha/api2/userverify?k=6LeN0vMZAAAAAIKVl68OAJQy3zl8mZ0ESbkeEk1m', everything also works. It feels like the site can recognize that the captcha is not being solved in the browser. I tested 2Captcha on other sites, with different captchas, everything works without problems, problems are encountered only on instacart.

What has been tested:
1. Different parameters in the api request - invisible 1/0 , enterprise 1/0, userAgent, proxy etc.
2. Various ways to submit a form, via a button, callback, javascript
3. Solve captcha yourself in app CaptchaBotRS
Anyone have any idea what the problem might be?
 
Last edited: